·
All is back to normal
Resolved
Monitoring
After concurrency adjustments execution delay is back to normal. Monitoring.
Investigating
Evaluations are taking longer to execute in EU