Resolved
The incident has been resolved.
Monitoring
We found a patch and currently work through the backlog. Things should recover within the next 10min.
Investigating
We're currently experiencing elevated ingestion times in the EU environment. Some events are processed with a delay of about 15 minutes. Our team is investigating.