Resolved
This issue has been resolved.
Monitoring
We've changed infrastructure capacity and observe that this mitigates the problems. We continue to observe the situation.
Investigating
We're investigating elevated loading times within the Langfuse UI and our APIs.