Resolved
The underlying incident with our infrastructure (https://statuspage.incident.io/clickhousecloud/incidents/01KT1G25S9PBKM7VJEB146680G) has been resolved.
Investigating
We're investigating an issue with elevated latencies and error rates in the EU environment.