Resolved
We've reverted a bad patch and see recovery. All routes should work as expected.
Identified
We have identified the issue and are rolling out a fix right now.
Investigating
We're observing elevated error rates for trace data reads on the UI and APIs. We're working on a fix.