Resolved
We caught up with our queues and have regular processing times again.
Identified
We're observing elevated processing times for newly ingested trace information on the Langfuse EU region. Right now, the delay is at approximately 10min. We see a downwards trend and are monitoring the situation.