Resolved
We've caught up again and improved our alerting to detect issues like this more proactively going forward.
Monitoring
Delays are below 60min again and trending further downwards.
Investigating
We're currently observing delays for data in the "Fast (Preview)" mode for users that are not using the latest Langfuse SDK versions. The current delay exceeds 1h and we're actively working through the backlog.