Resolved
Degraded database read replicas were re-created and now serving the public API path. Public API latency remains stable.
Monitoring
The API latencies seem to be normalizing
Identified
We identified a bad database replica. Public API traffic was shifted to a different set of replicas.
Investigating
We currently observe high latencies of our public APIs specifically `api/public/traces` and `api/public/observations`. We investigate the issue.
The new public APIs remain performant: https://langfuse.com/docs/api-and-data-platform/features/observations-api