Resolved
The backlog is being processed and we're below 60s processing delay.
Investigating
We're currently observing elevated processing times around ingestion for our European region. The current delay is about 6 minutes. Our team is investigating.