Resolved
We are now processing all llm as a judge executions in time.
Investigating
Due to very high ingestion traffic, we currently observe a delayed execution of LLM as a judge by 28 minutes. We currently scale the systems to process faster.
For more real time executions, migrate to observation LLM as a judge: https://langfuse.com/changelog/2026-02-13-observation-level-evals