Resolved
We've caught up on all outstanding events and are processing newly received events within our usual timeframes.
Investigating
We're currently experiencing event processing delays on our US regions. Events are processed with a delay of approximately 10 minutes. Our team is investigating.